Solved

cm:stacks:seed fails with error: Content Type creation failed

  • 16 April 2023
  • 2 replies
  • 131 views

Badge

Hello!

 

I deleted all the content types, assets, entries, everything from a Stack.

 

Then I ran: `csdx cm:stacks:seed --repo "contentstack/stack-starter-app" -k xxxxxxxxxxxxx`

 

I had run this command before without issues, but now I’m getting this error:

 

...

info: Started to seed content types
error: Content Type creation failed. Please try again. title is not unique.
error: Failed to migrate stack: Sandbox Mauricio. Please check error logs for more info
error: Failed to import content types

 

I’m 100% sure I deleted all content-types, entries, assets, before running the seed command, but still it seems to be a conflict. Tried the same steps more than once and had same results. 

 

Any ideas about what could be the issue?

icon

Best answer by Mauricio Robayo 16 April 2023, 05:55

View original

2 replies

Badge

Ok, so gave it one more try and it worked.

 

I guess it might have been some cache issue with the deleted content still been registered and generating the conflict.

Userlevel 5

@Mauricio Robayo We are glad to hear it worked, if you have the issue again please let us know. 

Reply